fumihumiのブログ

プログラミングの備忘録

最新のrubyをインストールできない。。。。

環境

  • macOS highSierra
  • homebrew
    • rbenv でrubyを管理

背景。

昨年末にruby2.5がリリースされているので、それに伴いローカル環境2.5を試したかったのだが、

rbenv install -l としても

2.5.0-dev

という正式版じゃないものがヒットしていた。。。。。

対応

$brew upgrade ruby-build $brew upgrade rbenv

この二つをすることで、

rbenv install -l のなかに無事2.5.0の安定版がヒットしました。

2.5.0のインストール

$ rbenv install 2.5.0
$ rbenv versions
-> 入っているか確認
$ rbenv global 2.5.0
$ rbenv rehash 
$ rbenv versions 
-> 左側のアスタリスクが2.5.0の行にあればおk

$ ruby -v
とし、2.5.0が返却されれば成功!!!!!!!!

以上、rubyの最新版のインスコについてでした